UK Only - Mobile connectivity EE network services.

Incident Report for Legrand Care Cloud Service Status

Resolved

CSL Infrastructure Engineers have monitored the stability and confirmed that all services are now restored. The incident is now closed.
Posted Jun 19, 2026 - 10:09 CEST

Monitoring

MNO roaming partner EE UK has applied the fix, and we are observing services restoring back to normal.
CSL will be releasing events held in smart reporting, which will mean ARCs may see path failures, likely closely followed by restores. Please wait 10 minutes before acting upon path failures. We will confirm when the entire process has concluded, and normal operation has continued
Posted Jun 18, 2026 - 17:20 CEST

Identified

14:36 - We are currently investigating an issue where we are observing a potential impact associated with EE services.

Relevant teams are engaged, and further investigation is ongoing. We will provide additional updates as more information becomes available

15:27 - We have received an update from our MNO provider, as they have identified an issue with the roaming partner and are actively working on a fix.

Reach IP impact is that units on EE that are impacted should roam to a new network. You may get a "no contact to portal" error, but looking at the last hours' statistics, most have now recovered and should be working as normal.
Posted Jun 18, 2026 - 16:56 CEST
This incident affected: M2M (M2M Service).