UK Only - Mobile Network Core - Tele2, rSIM UK/Europe

Incident Report for Legrand Care Cloud Service Status

Postmortem

Important Customer Information IoT – Root Cause Analysis February 2026

Date of Service Disruption: 10/02/2026 00:20 GMT – 10/02/2026 02:30 GMT.

P2 Incident: Network Partner Outage – Partial loss of telecommunication services.

Customer Impact:

Impacted devices were unable to start new data sessions, and there were partial disruptions with Mobile Terminating (MT) voice calls. Mobile Originated (MO) Voice, including VoLTE, was unimpacted.

Event Summary:

Some customers using Tele2 SIMs experienced a loss of telecommunication services during the time period stated above.

During a planned maintenance carried out by Tele2, approximately 10% of active data sessions were unintentionally interrupted. As a result, affected devices initiated simultaneous re-registration attempts to the network. The elevated volume of registration requests caused a significant increase in signalling traffic and caused processing congestion within HLR/HSS infrastructure provided by Tele2’s vendor. This resulted in temporary rejection of new registration attempts, which increased the impact to around 15% of devices. Tele2 engineering teams immediately implemented traffic stabilisation and load mitigation measures to restore network stability, and full service was restored by 02:30 GMT. The planned maintenance activity has been cancelled and will be rescheduled following completion of a full technical investigation.

Timeline:

At 00:20 GMT during the planned maintenance and synchronisation phase, 10% of active data sessions were interrupted due to an IP route change. An unexpected termination of data sessions triggered the affected user equipment to attempt immediate network re-registration. This simultaneous activity caused a signalling surge towards Tele2 network infrastructure that was immediately detected by Tele2 IoT monitoring systems. Subsequent analysis confirmed that elevated signalling traffic resulted in noticeable service degradation. The issue was immediately escalated and Tele2 support teams began a joint investigation with the responsible HLLR/HSS vendor to diagnose the cause. Tele2 engineering teams actively managed balancing system load, allowing the HLR/HSS vendor to gradually process the incoming traffic. Throughout the incident, key performance indicators showed steady recovery, with connection success rates rising and error rates decreasing. CSL3154V1 17022026 By 02:30 GMT full service had been restored.

Root Cause Analysis:

The incident was triggered by an unexpected impact of the planned maintenance which resulted in the disconnection of around 10% of active sessions. This initiated a mass re-registration event, as a large number of devices simultaneously attempted to re-establish connectivity. The resulting surge in signaling traffic caused congestion within the HLR/HSS infrastructure, activating protective throttling mechanisms that limited 2G/3G authentication and signaling requests. This led to temporary registration failures for further devices. In total, around 15% of CSL devices using Tele2 SIMs were impacted.

How did the outage impact critical connections (Telecare)?

Around 10% of devices using Tele2 SIMs will have lost connection to the network at 00:20, a further 5% will have subsequently been unable to start a new session. The impacted devices will have been unable to send or receive data, or receive voice calls. They will have been able to make outbound voice calls, including over VoLTE. Unimpacted devices will have performed as normal. Dual Core (DualSIM or rSIM) devices continued to work on the second profile, and CSL can see around 15% of rSIM connections switching to the backup profile.

Next Steps:

• CSL received notification of planned maintenance on the 2nd of February. After review, as this was 3rd party maintenance and no service impact was expected, CSL did not notify that this maintenance was taking place. Following this incident, CSL are carrying out a review of policies regarding notifications of 3rd party maintenance.

• Immediately following the incident, the HLR/HSS vendor completed a maintenance activity to fine-tune STP throttling parameters, reducing the risk of service impact from future traffic surges.

• Tele2 continues to work closely with their HLR/HSS vendor to further analyse the underlying factors that led to the message discards and the resulting data session interruptions.

• Tele2, together with their equipment vendor, is conducting a full technical investigation to determine the exact root cause of data sessions interruption.

Follow Up:

We would like to apologise again for any inconvenience caused. We understand the impact this causes on Manufacturers, Monitoring Centres and End Customers.

Posted Feb 19, 2026 - 16:28 CET

Resolved

CSL are aware of a degradation in Tele2 data sessions overnight, which impacted up to 15% of devices. This occurred between 00:30 and 02:30, with 4G sessions having restored by 01:00 UK time and 2G impacted until 02:00-02:30.

rSIMs switched to their backup profile as intended and continued to provide device data connectivity; Volte was not impacted.

CSL is working with Tele2 to understand the cause of this degradation and will follow up as appropriate.
No components were marked as affected by this incident.
Posted Feb 10, 2026 - 01:00 CET